Autodesk 3DSMAX 8 alo exporter Fehler

Mehr
26 Okt 2012 14:44 #52853 von maroon83
Salute zusammen,
zur Zeit ein hässliches Problem:
Beim Start von 3ds "Fehler 126: max2alamo.dle konnte nicht geladen werden".
In der Folge werden alo`s zwar importiert, jedoch untexturiert.
Sicherlich käme ich über Umwege an die dds Textur (via jpg und neue uvw), da ich aber ca 70 Modelle anpacken darf ist mir das momentan echt zu zeitaufwändig.
Hatte das Problem schon jemand?
Settings:
Win8, 3ds Version 8, incl. SP, importer und exporter plugins (FoC)

"We're not like the Ancients: We're not gonna sit around and wait. We don't back off; we have the capacity and the will to go kick their asses for a change." —John Sheppard

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Locutus
  • Locutuss Avatar
  • Offline
  • Administrator
  • Administrator
  • [SGMG] Project Co-Lead, Lead Coder, 3D-Artist
Mehr
26 Okt 2012 14:57 #52854 von Locutus

Open Customize > Preferences and go to the MAXScript tab. Set the initial heap allocation to a more comfortable amount, say, 150 MBytes. Close the preferences window.

Nachdem du das gemacht hast, musst du Max nochmal neu starten, sonst klappt es nicht. Im Zweifelsfall auch mehr MB freigeben, 150 könnten schon mal knapp werden.

Ansonsten musst du halt schauen, dass du im Exporter auch die richtigen Pfade für die Texturen angegeben hast, sowohl einmal vom Mod als auch einmal die extrahierten Vanilla-Texturen (EaW+FoC).

Hatte am Anfang damit auch einige Probleme, aber jetzt gehts.


...Darf ich fragen was du vor hast?^^


PS: Der Topic title spricht vom Exporter, aber es geht doch um den Importer?

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
26 Okt 2012 15:14 #52856 von maroon83
Ahoi.
Merci schonmal für die fixe Antwort.

Also es reichen nicht die Mod Pfade, sondern ich brauche auch einen Verweis auf die Vanilla Installation wenn ich dich richtig verstanden habe.

Grundsätzlich versuche ich alos in max zu importieren (zum Rendern), die export dle (max2alamo.dle) ist aber wohl für das import plugin Voraussetzung.

Ich versuch das gleich mal.....

EDIT:

Nope der Fehler ist leider konsistent. Import vom Mesh funktioniert 1A, Texturen: fail

"We're not like the Ancients: We're not gonna sit around and wait. We don't back off; we have the capacity and the will to go kick their asses for a change." —John Sheppard

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Locutus
  • Locutuss Avatar
  • Offline
  • Administrator
  • Administrator
  • [SGMG] Project Co-Lead, Lead Coder, 3D-Artist
Mehr
26 Okt 2012 15:37 #52857 von Locutus
Viele Modelle verwenden vanilla Texturen, darum würde ich die beiden Textures.meg extrahieren und zu den Texturpfaden hinzufügen, sonst gibt's schnell 'nen Fehler.

Hab aber gerade erst gelesen, dass du bereits beim Start einen Fehler angezeigt bekommst. Sowas ähnliches hatte ich unter Win7 x64; da musste man zuerst das DDS-Plugin verschieben, damit es geht. Ansonsten ggf. nochmal Importer und Exporter installieren und im Kompatibilitätsmodus Win7 einstellen.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
26 Okt 2012 16:15 #52860 von maroon83
So weit so gut:
DDS Plugs verschoben
- check
Import / Export Plugs
-check
Heap Size angepasst
-check
Kompatibilitätsmodus
-check
Vanilla EaW/FoC megs für Shader und Texturen extrahiert und Pfade angegeben
-check

Leider bleibt das Problem bestehen, geht sogar noch weiter:

"Warning: unable to load shader: MeshBumpColorize.fx"
"Warning: unable to load shader: MeshCollision.fx"
"Warning: unable to load shader: MeshAdditive.fx"
"Warning: unable to load shader: MeshShield.fx"

Aus der Meldungsbox bei 3ds. Dubios ist: Die sind vorhanden...

Ehe ich heut noch das Mauskabel abbeiß versuch ichs jetzt nochmal mit ner cleanen Installation.

"We're not like the Ancients: We're not gonna sit around and wait. We don't back off; we have the capacity and the will to go kick their asses for a change." —John Sheppard

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Locutus
  • Locutuss Avatar
  • Offline
  • Administrator
  • Administrator
  • [SGMG] Project Co-Lead, Lead Coder, 3D-Artist
Mehr
26 Okt 2012 17:32 #52861 von Locutus
Hab Max nicht zur Hand, aber die Shader müssen nach Max 8/Maps/fx oder so ähnlich.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
03 Nov 2012 09:17 #53046 von maroon83
Hey hey, so weit so gut:
Hab den Rechner komplett neu aufgesetzt (F**K Win8), bekomme jetzt auch keine Fehlermeldungen mehr bezüglich der Shader. Topp ;-)

Leider haben dei Meldungen nur einaml durchgetauscht, mit bestehendem Ergebnis: Geometrie ist Topp, Texturen Flopp.

"Run time error, unable to load texture xyz.dss"

Was mich dann aber doch irritiert da alle Pfade korrekt angegeben sind...

"We're not like the Ancients: We're not gonna sit around and wait. We don't back off; we have the capacity and the will to go kick their asses for a change." —John Sheppard

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Locutus
  • Locutuss Avatar
  • Offline
  • Administrator
  • Administrator
  • [SGMG] Project Co-Lead, Lead Coder, 3D-Artist
Mehr
03 Nov 2012 13:21 #53051 von Locutus
Den Error bekommst du unmittelbar beim Import?
Ich habe bei mir 3 Texturimportpfade angegeben: Den vom Mod, die extrahierten Texturen von EaW und die extrahierten von FoC.
Ansonsten weiß ich leider auch nicht, woran es liegen könnte.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.871 Sekunden