SWEAW 1.3 speichern funktioniert nicht

Mehr
02 Jun 2017 01:45 #87268 von radio
Hi alle,

nach langer Zeit wollte Ich mal wieder das Stargate-mod spielen aber speichern von GC funktioniert nicht.

Folgendes Setup: Win 8.1, GOG mit patch 1.3 und Disney-patch, 8GB RAM
Installation path: D:\GOGGames\Star Wars - Empire At War Gold\GameData (von wo Ich meine batches ausfuehre)

Batch:
set __COMPAT_LAYER=WIN98
sweaw LANGUAGE=ENGLISH MODPATH=Mods\Stargate

EAW startet, Ich kann auch spielen etc. aber wenn Ich speichern will bekomme Ich die Fehlermeldung nicht genug Speicherplatz bzw CTD (crash to desktop)

Habe auch schon versucht mit language=German
sweax.exe auf komp-modus (win98, XP)
sweax.exe als admin ausfuehren.
Normale EAW keine Probleme, genauso mit einem anderen Mod (gleiche setup in batch, naja bis auf modpath ;) )

Beim laden keine Fehlermeldung, wird auch als final 1.3 angezeigt.

Irgendwelche Ideen, Vorchlaege?

Vielen Dank fuer eure Hilfe (hoffe ich) ;)

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
02 Jun 2017 10:43 #87269 von Imperial
Knifflige Frage.
- Kann es sein, dass du gar keine Rechte für Schreibzugriff auf dein D Drive hast, oder die Windows UAC diesen Pfad blockiert:
C:\Users\???\AppData\Roaming\Petroglyph\Empire At War\Save
kann auch in D:\Users drinnen sein.

Obwohl, das es bei anderen Mods funktioniert weist eher auf ein Problem der alten Stargate-EAW installation hin:
- Du könntest versuchen in der Batch file dass wegzulassen: set __COMPAT_LAYER=WIN98

- Hast du irgendwelche ModMods installiert oder selber was daran gemoddet? Würde nämlich erklären wieso die save funktion vom Spiel fehlzuschlagen scheint. Da könntest du (sofern du noch weißt was genau es war) das kurz aus den Mod Ordner auf den Desktop wegzulegen für einen Test.
- Ansonsten wenn das nicht funktioniert, kann ich dir nur noch raten die 1.3 neu zu installieren.

Sind dir ansonsten noch irgendwelche GC spezifischen Bugs von der 1.3 aufgefallen?

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
02 Jun 2017 11:51 - 02 Jun 2017 12:14 #87272 von radio
Hi Imperial,

Ent. vergessen zu erwaehnen, das hatte Ich auch schon versucht wegzulassen ;)
Selbe Resultat. (auch nochmal die exe modifiziert, bleibt beim CTD beim speichern)
Rechte fuer Schreib/Lese sind da, funktioniert halt nur nicht mit Stargate-mod.
Wenn Ich modde, dann nur im mod folder ;)
Aber hier wollte Ich erst mal wieder einfach nur spielen, also alles im Orginal.
Und bevor Ich gepostet habe, habe Ich es 3 mal mit neuinstallation versucht (deutsch-englisch und wieder deutsch), immer gleich.
Jetzt als letztes nur mit der 1.3 Version, laut Beschreibung brauche Ich ja nicht die vorherigen zu Installieren, richtig?

Nur zur Anmerkung, Grund fuer die Zeile:
set __COMPAT_LAYER=WIN98
Damit laeuft SWEAW viel besser auf W8.1 ;)
Kaum noch stottern oder aehnliches.

Veraendert aber den save Ordner ; und ja auf beide sind volle Rechte vorhanden, sonst koennte Ich ja nicht Vanilla/andere Mods speichern ;)

Und alle Rechte fuer diesen Benutzer vorhanden.

Habe mir auch nochmal meinen defautl xml ordner angesehen, aber alles mit alten Datum, also auch kein modding geschehen.

Da Ich 1.3 noch nicht wirklich gespielt habe, nein nichts weiter aufgefallen, Iron-Man mit so einem Spiel, Nein danke ;)

EDIT:
Gerade nochmal ein bisschen rumgespielt mit der exe.
Wenn Ich bei der exe comp und admin hinzufuege -> CTD
Ansonsten, also ohne ^^ diese Einstellungen -> nicht genug Speicherplatz
ABER bei vanilla/enhancedEAW mod, funktioniert. (beides)
edit des edit ;)
Ja gerade nochmal mit der final_13_german.zip von hier versucht, immer das gleiche. Versuche jetzt nochmal mit der Englischen Version
Edit:
Englische Version (von hier) auch das gleiche.
Nur vorsichtshalber nochmal Vanilla gecheckt, ja ist auf 1.05
Letzte Änderung: 02 Jun 2017 12:14 von radio.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
02 Jun 2017 13:56 #87273 von Imperial
Oje, ja das debuggen ist sehe nervig.

Mir ist das auch schon passiert, dass immer wenn ich versuche auf Galaktischer Ebene zu speichern oder zu laden das Spiel abstürzt.

Damals war der Grund dafür dass ich beim modden vergessen habe in ./Data/scripts/story in einer .txt script datei das kommando "Text" vor den Beginn einer Massage einzutragen.

Du kanns dir vorstellen dass es mich den ganzen Tag gekostet hat bis ich das herausgefunden habe.

Die Frage, warum das bei 1.3 passiert, und warum ausgerechnet auf deiner 8.1 maschiene ist interessant. Und schwer zu beantworten.
Vielleicht funkt eine andere installierte Mod wie "Awakening of the Rebellion" oder Alliance dazwischen, indem sie etwas in das Verzeichniss des Vanillaspiels installiert und so die Bedingungen für Stargate ändert.

Vielleicht ist es wieder so ein Script fehler, du könntest versuchen Stargate/Data/Scripts kurzzeitig auf den Desktop zu legen und mal probieren.

Vielleicht ist es auch ein Einheiten Fehler, kann auch einfluss auf den speichervorgang nehmen wenn eine Einheit einen Xml fehler verursacht.

Da empfehle ich dass du Nikjzs, Aslenas oder Spinobreakers ModMod drauf installierst und überprüfst ob es damit funktioniert.

Du könntest auch verschen Spaceunitscapital.xml, Spaceunitsfrigate.xml, Spaceunitscorvette.xml, SpaceunitsFighters.xml und Squadrons.xml jeweils EINZELN aus den Xml ordner rauszunehmen und dann nochmal zu speichern versuchen.

Sehr mühselig ich weiß, danke dir also schon vielmals für die Geduld die du bisher investiert hast.

Ich muss mich die letzten drei Jahre lang mit Petroglyphs bugganfälligen Spiel herumschlagen, und praktisch mindestens einmal pro coding woche kommt solch ein eigenartiger Bug zum vorschein!

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
02 Jun 2017 19:08 - 02 Jun 2017 20:55 #87274 von radio
Ich versuche mal was du vorgeschlagen hast und sag dann Bescheid.

Und danke fuer die Muehe ;)

Und nur am Rande, keins meiner Mods fuer EAW durfte sich ins Vanilla schreiben ;)

Kann man das essen? -> dass du Nikjzs, Aslenas oder Spinobreakers ModMod <- ???? :O ;)

Haettest du dafuer links? Da Ich Firefox immer schliesse wenn Ich zocke/ausprobiere, kann Ich leider schlecht googeln , waere da auch fuer Hilfe dankbar. Leider sind ja viele Links mittlerweile tod :(

Und ist Awakening nicht fuer FOC?

EDIT:

Also nur bei 2 Files gab es eine Veraenderung.
SpaceunitsFighters.xml beim starten CTD, also kein Menue, kein nichts, auch keine Fehlermeldung.
Spaceunitscorvette.xml statt dem ueblichen CTD sagt EAW jetzt ungenuegender Speicherplatz. Sollte der Fehler also darin liegen?

Wobei Ich aber nicht verstehe warum Fighters zum CTD fuehrt. (ok, Vanilla hat IIRC kein Fighterfile, also doch vielleicht logisch ;) )

Wenn es an corvette liegt, mal ein bisschen nachgesehen:
<xxxSpace_Model_Name>Alkesh_D_DIE_00.ala</xxxSpace_Model_Name>
ist unter Alkesh -> <SpaceUnit Name="Alkesh_Kreuzer_Death_Clone">
sind ein paar dieser Eintraege vorhanden .......ist das richtig? Ich kenne eigentlich nur die Zeile
<Space_Model_Name>RV_Corvette_D.ALO</Space_Model_Name>
sollte es daran liegen?
EDIT:
Hat Anscheinend doch was damit zu tuen.... hatte alle <xxx mit <!xxx ausgetauscht, bleibt bei Speicherplatzproblem. Aber nicht mehr CTD. Oder Ich mache jetzt einen Gedankenfehler. Nur um klar zu stellen, normalerweise beim speichern CTD, mit dieser Veraenderung selbe Verhalten als waere File nicht da (siehe oben).
Letzte Änderung: 02 Jun 2017 20:55 von radio.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
02 Jun 2017 22:09 #87278 von Imperial

Und nur am Rande, keins meiner Mods fuer EAW durfte sich ins Vanilla schreiben

Bei den jenigen die mit automatischer .exe setup kommen kann man das kaum kontrollieren.

Kann man das essen? -> dass du Nikjzs, Aslenas oder Spinobreakers ModMod <- ????

Seine Modmods nicht, aber wenn du zufällig gerade Spinobreaker in der Nähe hast könntest du in seinen Arm beißen :D :a_appl2: :kawoosh:

Hab dir ne PM geschickt.

Eine weitere Addon Alternative währe Dark Jump

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Locutus
  • Locutuss Avatar
  • Offline
  • Administrator
  • Administrator
  • [SGMG] Project Co-Lead, Lead Coder, 3D-Artist
Mehr
03 Jun 2017 15:01 #87287 von Locutus
Dark Jump funktioniert aber nur mit der 1.0;)

radio schrieb: Haettest du dafuer links?

Du kannst alle ModMods für die 1.3 hier in unserer Download-Sektion finden:)


Was dein Problem angeht: Wenn du dir sicher bist, dass der vanilla Data-Ordner nicht verunreinigt ist (im Zweifelsfall Data-Ordner manuell löschen und neu installieren - Mods bleiben dabei enthalten) würde ich dir empfehlen die 1.3 noch einmal von dieser Seite herunterzuladen. Je nach dem von wo man die herunterlädt kommt die manchmal mit Installer und ich kann mir vorstellen, dass der unter neueren OSs schon mal Probleme macht. Also besser das Archiv selbst entpacken und an den richtigen Ort verschieben.
Dann sollte es eigentlich gehen.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
06 Jun 2017 08:31 #87306 von radio
okay, nur um auf nummer sicher zu gehen habe Ich neu installiert. Zwar nur mit unbenennen des alten Ordners und dann die GOG-version neu aufgespielt, danach noch den EAW_RAM_MPLobby_update.exe patch aufgespielt und danach von hier die 1.3 und den 1.31 patch von stargate installiert.

Immer noch das gleiche. Beim speichern einfach CTD. Keine Fehlermeldung kein nichts.

Frage/Idee fuer das Problem, koennte es sein das das Stargate mod Probleme damit hat wenn mehr als eine Sprachversion vorliegt?
GOG kommt mit 4 Sprachen, hat halt fuer mich den Vorteil das Ich durch "language=XXXX" einfach sagen kann welche Sprache Ich will ;)

Und Imperial, noch nicht mit PM (wieder ausprobiert) vielleicht spater heute.

langsam habe Ich wirklich keine Idee mehr.

bzw. vielleicht noch eine, kann es sein das dieses mod Probleme mit Leerzeichen hat?

Mein Pfad ist: D:\GOGGames\Star Wars - Empire At War Gold\EAWX

Normalerweise versuche Ich immer im 8.3 Format zu bleiben....

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
06 Jun 2017 09:36 #87307 von Imperial
Das mit der Sprache währe eine Idee, könnte sein, ich glaube aber eher nicht.

Vielleicht solltest du dein Vanilla Spiel (wenn nicht schon geschehen) mit den Meg extractor extrahieren, könnten Probleme mit der archivierung sein. Dann könntest du auch alle ungenutzten Sprachordner kurz weg verschieben und testen.

"Star Wars Empire ar War" im Pfad hat auch bei uns Leerzeichen, das wird es nicht sein.

Versuchen wir doch mal eine andere Herangehensweise:
Wo genau crasht dir das Spiel wenn du versuchst zu speichern, auf der galaktischen Map (vielleicht hat der KI Gegner zu viele Fighter gespawnt, erinnere mich an hunderte) - oder jeweils im Taktischen Weltraum Kampf ?
Das zweite würde auf eine fehlerhafte Einheit hinweisen.

Wenn es im Bodenkampf passiert heist das es stimmt was nicht mit den Boden einheiten. Und wenn es überall passiert heißt das ... genau garnichts ^^

Eine letzte Sache die ich vermuten kann ist, dass das Spiel auf den C Drive speichern will, das Spiel aber von D aus läuft und das irgendwie probleme macht.

Du könntest versuchen es auf C zu kopieren (wenn D extern ist einfach rauswerfen wenn nicht die origninalkopie liegen lassen) und den Registry key in EAW/1.0 (du weißt welchen) an den neuen Pfad kurz anpassen und versuchen von da aus zu starten.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
06 Jun 2017 10:41 #87308 von radio
meg extractor? Bin gerade auf dem Sprung.....

Speichern: Neustart, starte GC (114 Planets), pausiere und versuche zu speichern also noch nichts gebaut oder was auch immer ;)
Also um genau zu sein, GC -> Nachricht zu gemacht -> dann versuchen zu speichern -> CTD.
Hatte auch mit anderen GC's versucht, immer das gleiche.

Speichern ist auf C, konnte Ich leider nie aendern (s.o., haengt vom modus W95 oder nicht ab welches Verzeichniss genau, gibt halt zwei, scheint im Programm gespeichert zu sein, nicht Registry)

C wollte Ich eigentlich nicht dafuer nutzen, ist SSD , gibt es eigene Probleme mit einigen Spielen ;)

Und der Pfad ist der gleiche wie fuer Vanilla und andere mods (die funktionieren). c:blablablaAppData\Roaming\Petroglyph\Empire At War\Save

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 1.322 Sekunden