.alo Viewer, is there a way to attach all objects, basic question...

Mehr
05 Nov 2015 21:53 #76395 von vlnikolic
Hello

I wander is there a way to attach all objects on unit (eg ship) in Alamo Object Viewer?

eg
if I open EV_ACCLAMATOR.ALO parts are missing (because that are different .alo files).

Thanks

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
05 Nov 2015 22:13 #76397 von Imperial
Yeah well, if you use one of the 3DS Max Version that work wirh the Alo plugins: : 3DSMax 6, 8 and 9 (dont confuse with Max 2009). There might be additional alo importer/exporter Plugins for Max 2012 from petroglyphs new game Universe at War (not comfimd yet).

You need these plugins so you can access the "alamo proxie" in the dummy tag in 3DS Max, and the game engine + alo viewer will replace these alamo proxies by the models after they are named: Just place any Alamo proxie and give it the name of any .alo file in your mod directory that it is supposed to represent.

The alo viewer will use the same rotation direction and position as the proxies, so make sure you place them accurately into a model file.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
07 Nov 2015 18:14 #76430 von vlnikolic
thanks,

it worked!

i have only one (hopefully) minor question?

how can i turn on model textures and black background?

i've put correct locations of textures and shaders dir-s in plugin..

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
07 Nov 2015 18:46 #76431 von Imperial
If you use 3DS Max 6 or 8 simply copy the .fxo shader files from
C:\Program Files (x86)\LucasArts\Star Wars Empire at War Forces of Corruption\Data\Art\Shaders
into C:\Program Files (x86)\Autodesk\3ds Max 8\maps\fx

If you use Max 9, you need to rename their suffix from .fxo to .fx and place them into
C:\Program Files (x86)\Autodesk\3ds Max 9\maps\fx

The most important shaders are MeshBumpColorize.fx (which is for diffuse texture + Bumpmap) and MeshGloss.fx (Diffuse map only but make sure to lower the gloss parameter or it will be too glossy). You will additionally need MESHSHIELD, MESHCOLLISION, MESHSHADOWVOLUME and MESHADDITIVEOFFSET (for Light meshes).

If you wish to learn about more detais I'd sugget my tutorial collection, there you an see how to apply the textures through the shaders:
www.youtube.com/playlist?list=PLild8kZ8-...aGqLWuJdGFSSXlrv3B_9

And you can change the backtround color of the .alo viewer using the "background" button at the top, right side.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
07 Nov 2015 19:11 #76432 von vlnikolic
Hi

Thanks for fast reply.

I've just watched this video

I would like just to open model as it is, nothing to edit, just to open (similar to view in Alamo viewer) but with all objects of the model attached to it, with default textures colors and everything else.

It is strange to me that this procedure is so complicated.

:)

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
07 Nov 2015 19:30 #76434 von vlnikolic
... as well as this video

And when I import object it is in cyan or purple color, without any texture, although I put paths to the texture and shaders directory.
Beside mod's textures and shaders I put inside these directories original textures and shaders as well..

I know I am probably doing something wrong with this, but I do not know what..

: )

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
07 Nov 2015 21:20 #76436 von Imperial

And when I import object it is in cyan or purple color, without any texture, although I put paths to the texture and shaders directory.

Sounds like you forget to add the path of your mod texture directory or maybe you didnt placed the requiured shaders from the mod into the fx directory of Max (like I wrote into my last post).

An other thing you could try is opening the model you want to import in the alo viewer and click on File/Details
Then you can have a look at the Meshgloss and MeshBumpColorize Objects and find out which part of the model uses which texture in its "BaseTexture" parameter.
Then you could manually copy them from your moddir into the default directory of EAW or FFOC or both and try to import again.
If that wont work, now that you had a look and know which part is supposes to use which texture you can do some backwards ingeneering and apply the same shader with the correct textures. (dont forget to tweak the brightness paramters, they are important).

I know I am probably doing something wrong with this, but I do not know what..

Yeah every one went through this phase, its the most frustrating phase at the beginning until you get into this stuff. Just dont give up, experience will come by the time.

You might want to read through my erro log, it has some possible mistakes listed and their solution:
www.stargate-eaw.de/index.php/de/compone...eaw-anti-bugs-thread

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
16 Nov 2015 21:21 #76621 von vlnikolic
Hello Imperial

Thank you very much for your reply.
I am very happy that you are into the subject, and that you are kind to share your knowledge.

Unfortunately I have not solved this, although I've tried many times. I shall let it go for a while and than try again..
(not mod-ing, but this 3ds-max issue)

: )

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
17 Nov 2015 03:41 #76622 von Imperial
Yeah Im currently running against a (coding) wall as well already for days. Its very frustrating, but I know I am going to find a way to solve it.

Anyways, you're welcome ^^

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 2.186 Sekunden